Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email Anita Troy  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
Problems with 12v system by Anita Troy
Post New Message I have a 28' imperial aluma-lite travel trailer and my cord from the trailer is plugged into a power box that goes right to a power meter box well everything else plugged into the box is fine but my main power cord from the trailer keeps popping the breaker on this box. Nothing cold be plugged in and still won't work. Now if I leave it and pop the breaker back on for awhile it starts working again. Stays working for awhile then acts up again. I've noticed it happens more than not when it's raining. Just wondering if it has something to do with the battery. It's not the power box I've switched things around and same thing everything else is good except the cord to the trailer
All Messages in ThreadAuthorDate
Post New MessageProblems with 12v system Anita Troy 3-21-15  
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top