Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email Ray  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
Newmar Dutchstar (gas) loss of power by Ray
Post New Message We have a 30' Newmar Dutchstar (gas) 1999 model with a 1997 chassis. It will experience loss of power,check engine light comes on, hesitation and an eventual backfire. Turn it off and right back on and it will drive fine for about 100 miles and then repeat. On a long drive it eventually happens more often. Also tried kicking it into neutral, turn off switch, and re-start and problem would go away for another few miles, then do it all over again. We finally made it home 1200 miles later, just barely. It is an OBD1 and no codes are showing up. Mechanics we could find on the way home replaced an O2 sensor and fuel filter. Had a complete tune-up 1800 miles before this started. Have since replaced the coil and fuel pressure regulator. Ford mechanics can not find anything wrong and do not want it back lol? Could it be fuel injectors going bad, ECM problems? I saw Johnny had the same issue dated 10-26-14.
All Messages in ThreadAuthorDate
Post New MessageNewmar Dutchstar (gas) loss of power Ray 5-24-17  
  Reply to MessageRe: Newmar Dutchstar (gas) loss of power Lorin 8-21-17  
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top