Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email Thomas Chase  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
Electrical Thomas Chase 7-19-15  
Have a 2002 King of the Road 30' Royalite. Lost the 12V power to everything in the trailer when trying to operate on RV battery only. Checked battery, and it's good also have power to the fuse panel. If hooked up to AC power, or the trucks pig tail, everything operates. When I try to operate the jacks or slide outs it acts like it's got a low battery, but it's not. I'm stumped.
Re: Electrical BUBBA THE BUS TECH 7-20-15  
1ST If you follow the positive (+) cable from the battery to the trailer you will find it attaches to12 volt breakers and then splits up to run things. It sounds like the breakers to connect to the inside of the unit are tripped. Usually the jacks run off a fuse direct from the battery.

2nd These breakers have a tiny hidden reset button you need to push. Also these breakers are poor quality and the first time they trip is commonly the only time ever. I personally replaced mine with self resetting from the local auto parts store.

Good Luck
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top