Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email Kyle R. Morris  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
Power Boost problem? PLEASE HELP ME! Kyle R. Morris 7-24-10  
've read every entry on this site and I'm amazed that so many of us have had this problem (dating back to 2006!)
I have a 1995 Itasca Suncruiser. It's been in the shop three times already (this is # 4 ) with the following problem:

The parking brake will not disengage (light on)
I have NO power steering or brakes
when I shift from Park to Drive or Reverse, the RV WILL move....just not turn or STOP.
When I return the transmission to PARK and shut the motor off POWER STEERING ( Hydro. fluid ) POURS out of the overflow tube on the top of the canister.
The only solution my shop has found is to bleed the entire system of air and re-fill the Hydro fluid. It's almost like I have an air leak somewhere that allows air into the line and will not allow the fluid to
flow through the lines. Does this sound reasonable to anyone...and is there a better solution to it? This is getting costly!!!! Thanks in advance!
Re: Power Boost problem? PLEASE HELP ME! BUBBA THE BUS TECH 7-24-10  
I ran into a bus with a similar problem and found that the low presure return line had colapsed inside.
The pump was wining loud enough I could hear it over the Detroit deisel.
The lines should not be anything too special and may be retained by hose clamps instad of premade hose.
There could also be a leak in this line that allows air into the system
Either way
Good Luck
Check this next
Re: Power Boost problem? PLEASE HELP ME! Kyle R. Morris 7-24-10  
Bubba,

hmmm, interesting. I'll take a look and report back to you. Thanks for the heads up.
-kyle
Re: Power Boost problem? PLEASE HELP ME! Hershel Smith 8-14-10  
Kyle I had the same problem with my 1992 wennibago motor home in 2009 and could not find any body that could tell me what to do to fix it so being a mechanic on 18 wheelers for 36 years I set out on my own to find the problem and I finaly came up with the prblem.If you would like for me to explain to you how to fix the problem call me on my cell phone (704)699-5104
Re: Power Boost problem? PLEASE HELP ME! DAVID HANSEN 9-23-10  
Looking for a rebuild kit for the brake booster call me at 714-618-5330
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top