Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email John Mistretta  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
Allison transmission John Mistretta 12-29-10  
I have a 2001 Dutch Star motorhome with
a Catapiller 330 engine and a Allison transmission. I had it in storage for about a year. When I took it out of storage and was driving it to a local RV park, after stopping at a traffic light it shifted to second and then the lights on the shift key pad went out and the transmission guages stoped working. The transmission would not shift out of second. I made it to the RV park. When I turned the engine off I could not restart the engine because I could not put it in Neutral.
Re: Allison transmission BUBBA THE BUS TECH 12-30-10  
So you probably have a wiring harness issue.
By the way most of these get a signal from the trans computer saying Nuetral to allow starter operation. This means we need to know why your trans computer has gone completely brain dead.
To get your unit to start, turn the key on, Normal start up lights? if yes then find the relay that runs your staarter or go directly to the starter and hot wire it to crank the engine. You may need two people, Some one to hold the key in the start position and another to hot wire the starter. Be careful!!! The trans will engage second gear imediatly on start up!
Best way to attack this is to get the computer hooked to a scan tool and then go from there.
(%30 chance) that you have a bad ground or (20% chance) basic electrical power supply fault or broken wire at a conector at one of the conectors.
The other things could be bad Shift pad, bad computer, bad shift solinoid, and so on.
Good Luck
Re: Allison transmission daryl 2-15-13  
Allison temp light on dash stays on. Also has no power to computer port went you try to scanit. this a 3000mh in a 2001 Horizon. Flashes 6600 code at the shifter buttons.
Re: Allison transmission Walter 3-30-14  
How to change sump oil sensor
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top