Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email Rick  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
4L80E Transmission Problem Rick 2-8-09  
I've owned a '93' Fleetwood for 4 years,it has Only 26,000 Miles w/454 Gasser, I tow a small 4x4 (2000 Lbs), Check Engine light always has come on intermittently, usually during loads/hills. Lost 2nd,3rd,4th,& OD on last trip, limpped home in 1st! Sounds like same problem reacurring with others, an 'electrical' problem, maybe shift soliniod ground or the like. Any thoughts of wisdom before I take to the 'Man'.
Re: 4L80E Transmission Problem chris kleve 2-8-09  
Hi im haveing the same problem and tried everything have you got a answer yet thanks chris
Re: 4L80E Transmission Problem Rick 2-10-09  
Hi Chris,No answers Yet, lots of feelers out, let you Know what I find out.
Can you elaborate on what you've tried?
Re: 4L80E Transmission Problem Dave 2-13-09  
Was the speedo working when you were stuck in first gear? Have you checked the fuse for the trans? See my post above also.
Re: 4L80E Transmission Problem mike verdetto 3-4-09  
Scan it for codes. is the oil burnt puii the wire off the tranny that will go in limp mode 3rd gear see of you got 3rd. do you have pressure gages???check pressure. thoses gages save a lot of work with the fol chart
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top