Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email Ben  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
Re: 6v92 will not start after 20-45 minutes off, has run well by Ben
Post New Message I work on this in the Air Force, we have the same issue of loosing prime. Fuel pumps are rarely the issue. There should be a check valve prior to the primary filter (if you have a 2 filter set up), the check vavle will aid in preventing the fuel from draining back to the tank. Also, there could be a small pin on or dry rotted fuel hose. This type of engine I would suggest an external fuel pump for priming in emergencies.

Did this ever get fixed, if so, what was the fix?
All Messages in ThreadAuthorDate
Post New Message6v92 will not start after 20-45 minutes off, has run well todd- 10-22-07  
  Reply to MessageRe: 6v92 will not start after 20-45 minutes off, has run well Mark O. 10-23-07  
  Reply to MessageRe: 6v92 will not start after 20-45 minutes off, has run well Ben 10-13-08  
  Reply to MessageMy 6v92 started hit 90lbs air &died Ray Green 12-18-11  
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top