Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email Keith  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
Re: Flame stays on but only a few seconds by Keith
Post New Message Hi Glenn, if this is the first run of the season, the first thing I would check is for blockage/bug nests in the exhaust tube and burner chamber. This is common if a unit sits all summer without using the furnace. Make sure the furnace is getting between 11 and 14.5 volts and the motor is running at full speed to keep the sail switch engaged. Next I would clean the contacts on the circuit board and blow out any lint in the plug. If it still fails, take the board to an RV shop and have it tested. This shouldn't cost if it's a decent shop. Other causes could be the electrode is out of adjustment or defective, low LP pressure, or defective/holy burner chamber. It's easier to troubleshoot there than from here..... good luck
All Messages in ThreadAuthorDate
Post New MessageFlame stays on but only a few seconds Glenn P Christie 10-23-17  
  Reply to MessageRe: Flame stays on but only a few seconds Keith 10-25-17  
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top