Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email DEAN GRIFFIN  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
Hydro flame 8525-II DEAN GRIFFIN 2-9-03  
BURNER NOT IGNITING-JUST REPLACED NEW DINOSAUR BOARD WITH SAME RESULTS.I CAN HEAR
THE IGNITOR TRYING THREE TIMES.ELECTRODES
LOOKED GOOD.I HAVE BLOWN AIR THROUGH INTAKE
AND EXHAUST TUBES.
ANY SUGGESTIONS?....DEAN
Re: hydro flame 8525-II Joe 2-9-03  
If you have checked the thermostat, and are sure you have a supply of gas, and the blower is running at speed, then there are two things to check, the sail" switch or the gas valve. The sail switch can possibly freeze up and it won't move when the blower coems on. Thet gives the board a signal to open the gas valve which is also controlled by the thermostat. With the unit running you can check voltage to both sides of the switch. It should have power to both sides. If you do, then check voltage to the gas valve.
Re: hydro flame 8525-II dean griffin 2-10-03  
Joe-thanks for your input..however,i did
leave out a couple of things.when the
thermostat was first set at at the desired
temperature,the burner would ignite and the
blower would come on until the temperature was satisfied.as the temperature fell and the thermostat activated the furnace the second time, the blower would come on but
the burner would not ignite.days after,it
got progressively worse and the burner would not ignite at all.
that's when i changed the ignition board.
does your advice remain the same or is there more?..........dean
Re: hydro flame 8525-II Joe 2-10-03  
So if you put in the Dinosaur board, the LED should lite up green when the power is on, thermostat is calling for heat, and the high limit switch is in the closed position with the fan running. As the sail switch operates, there is a twenty second delay, six second fire and at the same time you should hear a click from the gas valve opening. The LED should turn red and the furnace should fire up.
For instant (non delay) ignition, you have to remove the jumper in the upper right corner. If all that is happening, check the orfice for obstruction.
Re: hydro flame 8525-II DEAN GRIFFIN 2-13-03  
TO RECAP........IF THE IGNITOR {ELECTRODE} IS TRYING TO LIGHT THE BURNER 3 TIMES BEFORE LOCKOUT,THEN CAN I ASSUME THAT POWER HAS PASSED THROUGH THE TIME DELAY,SAIL, LIMIT SWITCHES AND BOARD THEN BACK TO THE ELECTRODE ?
CAN I ELIMINATE THOSE SWITCHES AND THE BOARD AS PROBABLE CAUSES ?
CAN I NOW CONFINE MY TROUBLESHOOTING TO
THE ELECTRODE GAP,BURNER & GAS VALVE AND
COILS ?..........MANY THANKS,DEAN
Re: hydro flame 8525-II Joe 2-13-03  
Yes, but you must check the presence of gas, followed by the opening of the gas valve. Do you smell propane outside after the three tries of the igniter? If you do, then check the igniter. If you don't check the gas valve.
Re: hydro flame 8525-II DEAN GRIFFIN 2-21-03  
DUE TO THE LOCATION OF THE HIGH LIMIT
SWITCH,I PLAN TO REPLACE IT BEFORE AS A
PRECAUSIONARY MEASURE BEFORE I BUTTON
EVERYTHING UP.I HAVE AS A REPLACEMENT, PART# 6176...HOWEVER,I AM GETTING SOME
CONFLICTING INFORMATION FROM DIFFERENT
VENDORS THAT "YES" IT'S THE RIGHT PART
AND OTHERS SAY IT IS PART# 5132T.
WHICH ONE IS CORRECT OR ARE THEY INTERCHANGEABLE ?....THANKS,DEAN
Re: hydro flame 8525-II Joe 2-21-03  
I'm sorry, but that technical I can't get. Part numbers change daily and it would not be possible to keep up with them unless you were in the parts business. Yours can be tested with an ohm meter and a heat gun. Cold it should be closed and heated it should break the current. Cycle it 10 or 15 times to see if it works. I'm not sure what to tell you on the replacement one. Too hot and it could damage the heat chamber and too cold and you would get insufficient heat.
Re: hydro flame 8525-II Greg Ashcraft 4-8-03  
I get the EXACT same indications as Dean Griffin. WOrked, then gradually got worse. then wont light at all, I can smell gas at the outlet, hear the valve open, hear the ignightor. Any suggestions? Looks like a real BIT_ _ H to pull this thing out. Thanks Greg.
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top