Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email Matthew  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
Motorhome is dying on me Matthew 9-4-17  
I'm a couple days into a 4200 mile trip and my 1991 Tioga Arrow motorhome (Ford E350-based with 7.5L 460i engine) is giving me some problems. I'll be driving along and it will start to lack power but only for fractions of a second at first. It will get progressively worse until the engine dies, even if I immediately pull over and put it in park. It will then refuse to start. The engine will turn over but it acts like it doesn't have any fuel/spark/something. After 10-60 minutes, I can start it back up immediately (like normal) and drive for 4-160 miles before it repeats. A mechanic replaced the fuel pump and fuel filter and it drove fine for 160 miles... but then it had been sitting for a couple hours so it might have driven fine regardless of the pump/filter. A couple times when the engine died, it threw a CEL. I tried scanning it at AutoZone but their scanner never was able to pull any codes. The CEL went out whenever it was ready for me to start driving again.

Any idea what this could be or what I could try next?

Thanks!
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top