Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email Chris Manier  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
HydroFlame 8531 fails to light Chris Manier 4-3-17  
HydroFlame 8531
Replaced burner assembly last mionth. Fan works. Igniter works. Valve coils check out. But it takes about 6 cycles before it lights, if it lights at all.
This is interesting: When I put my hand over the exhaust grill momentarily, voila! Instant ignition! It seems the gas is not lingering at the burner long enough for the spark to find it.
Any ideas? There could be a box of doughnuts in it for you...
Re: HydroFlame 8531 fails to light Bubba The Bus Tech 4-5-17  
Most common cause of your symptoms is either a damaged ceramic insulator on the igniter or more likely the igniter probe is sparking in the wrong location.

Most furnaces have an exact spot on the burner that the spark must jump too. Usually a little round spot in the middle of the burner slots or holes or whatever depending on the design.

Also if the gap is too large it will cause the same issue

Good Luck
Re: HydroFlame 8531 fails to light Steven Pangborn 4-13-17  
Hydroflame heater won't ignite, blower comes on, I hear the click of the igniter but no flame, I need help please!! Thanks
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top