Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email Tina  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
Furnace Tina 4-19-14  
I have a hydro flame furnace model 8520-II.i turn the thermostat on the fan comes on than it clicks like it wants to light but doesn't.
Re: Furnace Keith 4-21-14  
Hi Tina, If the igniter is in fact working I'd first check for propane at the furnace, (LP pressure check advisable) then for an obstuction in the exhaust tube like bug nests, next pull the burner assembly and check for a rusted out burner, the igniter gap, 1/8" tip to burner face and tip gap if a ground and igniter tip. Remove the LP orifice and look for an obstruction, look for ob's in the burner chamber. Usually the gas valves are pretty reliable but you can't count out a bad valve. Or call an RV tech or take it to a shop and have it checked out. Good luck
Re: Furnace SamuelBates 5-19-14  
If the furnace is not lighting the things to check:
1. Thermostat settings
2. Furnace 'service' switch may beturned to off position (check back of the access panel)
3. Probably low voltage than required (check battery charge, power center is turned on and breakers enabled)
4. propane flow blockage(tank or regulator turned off, out of gas, regulator set wrong or damaged)
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top