Motorhome & Recreational Vehicle Resource

Since 1996

Search RV-Coach Online

Email Author email chuck  Reply to Message reply to message  Post New Message post new message      search forums
ATTENTION: DO NOT POST ADS IN FORUMS!
All Postings that advertise items for sale will be deleted from the Discussion Forum. You may post sale items for free in the Classifieds section. Sign up now.
All Messages in ThreadAuthorDate
Haydro therm 8500-11 chuck 10-12-13  
Furnace will start fan running but fails to light burner could this be the board?
Re: haydro therm 8500-11 Keith 10-12-13  
Hi Chuck, For a Hydro Flame 85xx series II (2) furnace. A few things to check are: That there's 10.5 - 14 volts DC to the furnce. (prefer 12 - 14) A slow motor will not trip the sail switch which will not let the gas valve open. Remove the plug connector on the edge of the board and check for for lint/dirt and clean the board contacts with an eraser. Check the exhaust tube for bug nests. Wiggle all accessible wire connections for good contact especially the ground. If none of this helps, take the board to an RV shop and have it tested before you start replacing parts. If it's good there are numerous things it could be. But most common are bad sail switch or limit switch. Series II is getting up there on age. Good luck
Required fields in red
For more info about a field, place your mouse over the More Info icon.
Subject:
Your Name:
Your Email:
Message:



Code is case-sensitive. Helps stop SPAM.
       


Advertise Here
Get Media Kit NOW!






Get Media Kit to Advertise!

Advertiser Links

Back to Top